安装wget命令
yum install wget -y #centos
apt -y install wget #ubuntu

通用单网卡方案 (适应于绝大多数VPS)

下载镜像
wget https://download.mikrotik.com/routeros/6.45.8/chr-6.45.8.img.zip -O chr.img.zip

解压缩
gunzip -c chr.img.zip > chr.img

挂载镜像
#注意:fdisk -lu chr.img 查看start值是否为1,不是,侧用当前数字 *512
mount -o loop,offset=512 chr.img /mnt

获取地址与网关 与 赋入变量
#有的网卡不是eth0 可以用ifconfig命令查看

ADDR0=`ip addr show eth0 | grep global | cut -d' ' -f 6 | head -n 1`

GATE0=`ip route list | grep default | cut -d' ' -f 3`

mkdir -p /mnt/rw

echo "/ip address add address=$ADDR0 interface=[/interface ethernet find where name=ether1]

/ip route add gateway=$GATE0

" > /mnt/rw/autorun.scr

卸载镜像

umount /mnt

立即重新挂载所有的文件系统为只读

echo u > /proc/sysrq-trigger

DD ros镜像

dd if=chr.img bs=1024 of=/dev/sda && reboot

立即重新启动机器

echo "b" > /proc/sysrq-trigger

另一款 双网卡的样本 (注意分清 内外 网卡)

196.10.68.0/24 dev eth0  proto kernel  scope link  src 196.10.68.24 

169.254.0.0/16 dev eth0  scope link  metric 1002 

169.254.0.0/16 dev eth1  scope link  metric 1003 

10.0.0.0/8 dev eth1  proto kernel  scope link  src 10.0.87.152 

default via 196.10.68.1 dev eth0

wget https://download.mikrotik.com/routeros/6.45.8/chr-6.45.8.img.zip -O chr.img.zip

gunzip -c chr.img.zip > chr.img

mount -o loop,offset=512 chr.img /mnt

ADDR0=`ip addr show eth0 | grep global | cut -d' ' -f 6 | head -n 1`

ADDR1=`ip addr show eth1 | grep global | cut -d' ' -f 6 | head -n 1`

GATE0=`ip route list | grep default | cut -d' ' -f 3`

GATE1=`ip route list | grep '10.0.0.0/8' | cut -d' ' -f 9`

mkdir -p /mnt/rw

echo "/ip address add address=$ADDR0 interface=[/interface ethernet find where name=ether1]

/ip address add address=$ADDR1 interface=[/interface ethernet find where name=ether2]

/ip route add gateway=$GATE0

/ip route add dst-address=10.0.0.0/8 gateway=$GATE1

" > /mnt/rw/autorun.scr

umount /mnt

echo u > /proc/sysrq-trigger

dd if=chr.img bs=1024 of=/dev/vda && reboot

Ros 授权相关

Ros 系统是商业软件 ,本身是需要授权的,在没有授权的情况下使用,网卡限制速率(1Mbps),不过Ros CHR版本是支持免费试用的,只需要去官方网站 https://mikrotik.com/client 注册一个帐号,然后去邮箱获取帐号通过验证,接着返回到Ros系统  进入 System > License  填入你刚刚注册的帐号登录即可,试用期是两个月时长,但根据我的使用情况来看,只要系统不进行更新,是可以一直免费试用下去的,功能不受限制。

作者 Qi, Asura

发表评论

您的电子邮箱地址不会被公开。